GetSharedSizes Method


Routing Preference Manager Get Shared Sizes Method

Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> GetSharedSizes(
	double size,
	ConnectorProfileType shape
)

Parameters

size Double
The size to search for.
shape ConnectorProfileType
The profile shape of segment object.

Return Value

IList ElementId
A list of all segments that define a given size.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also