GetSharedSizes Method


Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public IList<ElementId> GetSharedSizes(
	double size,
	ConnectorProfileType shape
)
Visual Basic
Public Function GetSharedSizes ( _
	size As Double, _
	shape As ConnectorProfileType _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSharedSizes(
	double size, 
	ConnectorProfileType shape
)

Parameters

size
Type: SystemDouble
The size to search for.
shape
Type: Autodesk.Revit.DBConnectorProfileType
The profile shape of segment object.

Return Value

A list of all segments that define a given size.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also