Routing |
Gets a list of all segments of a given profile shape that define a given size.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- size Double
- The size to search for.
- shape ConnectorProfileType
- The profile shape of segment object.
Return Value
IList ElementIdA list of all segments that define a given size.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |