Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ExporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- Plane
- Type: Autodesk.Revit.DB Plane
The plane in which the face handles must lie.
- ProjDir
- Type: Autodesk.Revit.DB XYZ
The normal vector to the input plane.
- epsilon
- Type: System Double
The epsilon value used to process surfaces.
- createRepresentations
- Type: System Boolean
Indicates if this should also create geometry representation handles.
Return Value
The new geometry info container.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |