CreateFaceGeometryInfo Method (ExporterIFC, Plane, XYZ, Double, Boolean)


IFCGeometry Info Create Face Geometry Info(Exporter IFC, Plane, XYZ, Double, Boolean) Method

Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCGeometryInfo CreateFaceGeometryInfo(
	ExporterIFC ExporterIFC,
	Plane Plane,
	XYZ ProjDir,
	double epsilon,
	bool createRepresentations
)

Parameters

ExporterIFC ExporterIFC
The exporter.
Plane Plane
The plane in which the face handles must lie.
ProjDir XYZ
The normal vector to the input plane.
epsilon Double
The epsilon value used to process surfaces.
createRepresentations Boolean
Indicates if this should also create geometry representation handles.

Return Value

IFCGeometryInfo
The new geometry info container.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also