CreateFaceGeometryInfo Method (ExporterIFC, Plane, XYZ, Double, Boolean)


Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static IFCGeometryInfo CreateFaceGeometryInfo(
	ExporterIFC ExporterIFC,
	Plane Plane,
	XYZ ProjDir,
	double epsilon,
	bool createRepresentations
)
Visual Basic
Public Shared Function CreateFaceGeometryInfo ( _
	ExporterIFC As ExporterIFC, _
	Plane As Plane, _
	ProjDir As XYZ, _
	epsilon As Double, _
	createRepresentations As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateFaceGeometryInfo(
	ExporterIFC^ ExporterIFC, 
	Plane^ Plane, 
	XYZ^ ProjDir, 
	double epsilon, 
	bool createRepresentations
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
Plane
Type: Autodesk.Revit.DBPlane
The plane in which the face handles must lie.
ProjDir
Type: Autodesk.Revit.DBXYZ
The normal vector to the input plane.
epsilon
Type: SystemDouble
The epsilon value used to process surfaces.
createRepresentations
Type: SystemBoolean
Indicates if this should also create geometry representation handles.

Return Value

The new geometry info container.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also