IFCGeometry |
Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static IFCGeometryInfo CreateFaceGeometryInfo(
ExporterIFC ExporterIFC,
Plane Plane,
XYZ ProjDir,
double epsilon,
bool createRepresentations
)
Parameters
- ExporterIFC ExporterIFC
- The exporter.
- Plane Plane
- The plane in which the face handles must lie.
- ProjDir XYZ
- The normal vector to the input plane.
- epsilon Double
- The epsilon value used to process surfaces.
- createRepresentations Boolean
- Indicates if this should also create geometry representation handles.
Return Value
IFCGeometryInfoThe new geometry info container.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |