Gets the added curves that will represent the bar at index barIndex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barIndex
- Type: System Int32
The index of the bar. Should be a number between 0 and GetNumberOfBarGeometry() - 1.
Return Value
Returns the curves that will represent the bar at index barIndex. The hooks plane normals will be applied on these curves.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barIndex is not in the range [ 0, GetNumberOfBarGeometry()-1 ]. |