Rebar
|
Gets the added curves that will represent the bar at index barIndex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- barIndex Int32
- The index of the bar. Should be a number between 0 and GetNumberOfBarGeometry() - 1.
Return Value
IList CurveReturns the curves that will represent the bar at index barIndex. The terminations' plane normals will be applied on these curves.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barIndex is not in the range [ 0, GetNumberOfBarGeometry()-1 ]. |