GetAddedBarGeometry Method


Rebar Trim Extend Data Get Added Bar Geometry Method

Gets the added curves that will represent the bar at index barIndex.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Curve> GetAddedBarGeometry(
	int barIndex
)

Parameters

barIndex Int32
The index of the bar. Should be a number between 0 and GetNumberOfBarGeometry() - 1.

Return Value

IList Curve
Returns the curves that will represent the bar at index barIndex. The hooks plane normals will be applied on these curves.
Exceptions
Exception Condition
ArgumentOutOfRangeException barIndex is not in the range [ 0, GetNumberOfBarGeometry()-1 ].
See Also