GetAddedBarGeometry Method


Gets the added curves that will represent the bar at index barIndex.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public IList<Curve> GetAddedBarGeometry(
	int barIndex
)
Visual Basic
Public Function GetAddedBarGeometry ( _
	barIndex As Integer _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetAddedBarGeometry(
	int barIndex
)

Parameters

barIndex
Type: SystemInt32
The index of the bar. Should be a number between 0 and GetNumberOfBarGeometry() - 1.

Return Value

Returns the curves that will represent the bar at index barIndex. The hooks plane normals will be applied on these curves.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException barIndex is not in the range [ 0, GetNumberOfBarGeometry()-1 ].

See Also