Create Method


Returns an new created ExportPDFSettings element in the document with specified settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static ExportPDFSettings Create(
	Document document,
	string name,
	PDFExportOptions options
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	name As String, _
	options As PDFExportOptions _
) As ExportPDFSettings
Visual C++
public:
static ExportPDFSettings^ Create(
	Document^ document, 
	String^ name, 
	PDFExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Document where the settings will be created.
name
Type: SystemString
Name to the settings.
options
Type: Autodesk.Revit.DBPDFExportOptions
The options to be set.

Return Value

New instance of ExportPDFSettings just created in the document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- Setting name.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also