Export |
Returns an new created ExportPDFSettings element in the document with specified settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ExportPDFSettings Create(
Document document,
string name,
PDFExportOptions options
)
Parameters
- document Document
- Document where the settings will be created.
- name String
- Name to the settings.
- options PDFExportOptions
- The options to be set.
Return Value
ExportPDFSettingsNew instance of ExportPDFSettings just created in the document.

Exception | Condition |
---|---|
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- Setting name. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |