Creates a new instance of a generic zone and adds it to the document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
- name
- Type: SystemString
The name of the generic zone to be created.
- domainData
- Type: Autodesk.Revit.DB.AnalysisGenericZoneDomainData
The specific domain requirements for the generic zone.
- levelId
- Type: Autodesk.Revit.DBElementId
The base level on which the generic zone will be created.
- curveLoops
- Type: System.Collections.GenericIListCurveLoop
The loops that define the lines, curves and areas that overlap or crosses the elements you want to belong to the zone. Multiple loops are allowed, they can be open or closed, but they should be on the same horizontal plane.
Return Value
The newly created generic zone.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The ElementId levelId is not a Level. -or- The curve loops in the input array are empty. -or- The input curve loops do not all lie in the same horizontal plane. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |