Generic |
Creates a new instance of a generic zone and adds it to the document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static GenericZone Create(
Document doc,
string name,
GenericZoneDomainData domainData,
ElementId levelId,
IList<CurveLoop> curveLoops
)
Parameters
- doc Document
- The document where the element will be created and added.
- name String
- The name of the generic zone to be created.
- domainData GenericZoneDomainData
- The specific domain requirements for the generic zone.
- levelId ElementId
- The base level on which the generic zone will be created.
- curveLoops IList CurveLoop
- The loops that define the lines, curves and areas that overlap or crosses the elements you want to belong to the zone. Multiple loops are allowed, they can be open or closed, but they should be on the same horizontal plane.
Return Value
GenericZoneThe newly created generic zone.

Exception | Condition |
---|---|
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The ElementId levelId is not a Level. -or- The curve loops in the input array are empty. -or- The input curve loops do not all lie in the same horizontal plane. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |