Create Method


Generic Zone Create Method

Note: This API is now obsolete.


Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Prefer createSketchBased instead.")]
public static GenericZone Create(
	Document doc,
	string name,
	GenericZoneDomainData domainData,
	ElementId levelId,
	IList<CurveLoop> curveLoops
)

Parameters

doc Document
name String
domainData GenericZoneDomainData
levelId ElementId
curveLoops IList CurveLoop

Return Value

GenericZone
See Also