A filter used to match elements which are owned by a particular view.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This filter is a quick filter.
Quick filters operate only on the ElementRecord, a low-memory class which has
a limited interface to read element properties. Elements which are rejected
by a quick filter will not be expanded in memory.
Examples
Copy
C#
// Use ElementOwnerView filter to find TextNotes in the active view
// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);
// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();
// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
Copy
VB.NET
' Use ElementOwnerView filter to find TextNotes in the active view
' Create an ElementOwnerView filter with id of active view
Dim elementOwnerViewFilter As New ElementOwnerViewFilter(document.ActiveView.Id)
' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find TextNotes only
Dim collector As New FilteredElementCollector(document)
Dim textNotesOfActiveView As ICollection(Of Element) = collector.WherePasses(elementOwnerViewFilter).OfClass(GetType(TextNote)).ToElements()
' Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
Dim notOwnedFilter As New ElementOwnerViewFilter(document.ActiveView.Id, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notOwnedByViewFounds As ICollection(Of Element) = collector.WherePasses(notOwnedFilter).OfClass(GetType(TextNote)).ToElements()
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementOwnerViewFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementOwnerViewFilter