ElementOwnerViewFilter Class


Element Owner View Filter Class

A filter used to match elements which are owned by a particular view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementOwnerViewFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementOwnerViewFilter : ElementQuickFilter

The ElementOwnerViewFilter type exposes the following members.

Constructors
Name Description
Public method ElementOwnerViewFilter(ElementId) Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method ElementOwnerViewFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.
Top
Properties
Name Description
Public property ViewId The view id.
Top
Methods
Name Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also