Element |
A filter used to match elements which are owned by a particular view.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementOwnerViewFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementOwnerViewFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementOwnerViewFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view. |
![]() | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view. |

Name | Description | |
---|---|---|
![]() | ViewId | The view id. |

Name | Description | |
---|---|---|

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.