ElementOwnerViewFilter Class


Element Owner View Filter Class

A filter used to match elements which are owned by a particular view.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementOwnerViewFilter : ElementQuickFilter

The ElementOwnerViewFilter type exposes the following members.

Constructors
Name Description
Public method ElementOwnerViewFilter(ElementId) Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method ElementOwnerViewFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.
Top
Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Public property ViewId The view id.
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
// Use ElementOwnerView filter to find TextNotes in the active view

// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
    collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();

// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
    collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
See Also