LightFamily Class


Light Family Class

This class encapsulates light family information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightFamily

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LightFamily : IDisposable

The LightFamily type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LightFamily
Public method GetLightDistributionStyle Returns a LightDistributionStyle value for the light distribution
Public method Static member GetLightFamily Creates a light family object from the given family document
Public method GetLightShapeStyle Returns a LightShapeStyle value for the light shape
Public method GetLightSourceTransform Returns a Transform value for the transform of light source.
Public method GetLightType Return a LightType object for the light type at the given index
Public method GetLightTypeName Return the name for the light type at the given index
Public method GetNumberOfLightTypes Return the number of light types contained in this light family
Public method SetLightDistributionStyle Set the light distribution style to the given shape distribution
Public method SetLightShapeStyle Set the light shape style to the given shape style
Top
See Also