Light |
This class encapsulates light family information.

System Object
Autodesk.Revit.DB.Lighting LightFamily
Autodesk.Revit.DB.Lighting LightFamily
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The LightFamily type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the LightFamily |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLightDistributionStyle | Returns a LightDistributionStyle value for the light distribution |
![]() ![]() | GetLightFamily | Creates a light family object from the given family document |
![]() | GetLightShapeStyle | Returns a LightShapeStyle value for the light shape |
![]() | GetLightSourceTransform | Returns a Transform value for the transform of light source. |
![]() | GetLightType | Return a LightType object for the light type at the given index |
![]() | GetLightTypeName | Return the name for the light type at the given index |
![]() | GetNumberOfLightTypes | Return the number of light types contained in this light family |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetLightDistributionStyle | Set the light distribution style to the given shape distribution |
![]() | SetLightShapeStyle | Set the light shape style to the given shape style |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |