ElementTransformUtils Class


Element Transform Utils Class

A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ElementTransformUtils

The ElementTransformUtils type exposes the following members.

Methods
Name Description
Public method Static member CanMirrorElement Determines whether element can be mirrored.
Public method Static member CanMirrorElements
Public method Static member CopyElement Copies an element and places the copy at a location indicated by a given transformation.
Public method Static member CopyElements(Document, ICollection ElementId , XYZ)
Public method Static member CopyElements(Document, ICollection ElementId , Document, Transform, CopyPasteOptions)
Public method Static member CopyElements(View, ICollection ElementId , View, Transform, CopyPasteOptions)
Public method Static member GetTransformFromViewToView Returns a transformation that is applied to elements when copying from one view to another view.
Public method Static member MirrorElement Creates a mirrored copy of an element about a given plane.
Public method Static member MirrorElements
Public method Static member MoveElement Moves one element by a given transformation.
Public method Static member MoveElements
Public method Static member RotateElement Rotates an element about the given axis and angle.
Public method Static member RotateElements
Top
See Also