Element |
A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).

System Object
Autodesk.Revit.DB ElementTransformUtils
Autodesk.Revit.DB ElementTransformUtils
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ElementTransformUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CanMirrorElement | Determines whether element can be mirrored. |
![]() ![]() | CanMirrorElements | |
![]() ![]() | CopyElement | Copies an element and places the copy at a location indicated by a given transformation. |
![]() ![]() | CopyElements(Document, ICollection ElementId , XYZ) | |
![]() ![]() | CopyElements(Document, ICollection ElementId , Document, Transform, CopyPasteOptions) | |
![]() ![]() | CopyElements(View, ICollection ElementId , View, Transform, CopyPasteOptions) | |
![]() ![]() | GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view. |
![]() ![]() | MirrorElement | Creates a mirrored copy of an element about a given plane. |
![]() ![]() | MirrorElements | |
![]() ![]() | MoveElement | Moves one element by a given transformation. |
![]() ![]() | MoveElements | |
![]() ![]() | RotateElement | Rotates an element about the given axis and angle. |
![]() ![]() | RotateElements |