ElementTransformUtils Class


Element Transform Utils Class

A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ElementTransformUtils

The ElementTransformUtils type exposes the following members.

Methods
Name Description
Public method Static member CanMirrorElement Determines whether element can be mirrored.
Public method Static member CanMirrorElements Determines whether elements can be mirrored.
Public method Static member CopyElement Copies an element and places the copy at a location indicated by a given transformation.
Public method Static member CopyElements(Document, ICollection ElementId , XYZ) Copies a set of elements and places the copies at a location indicated by a given translation.
Public method Static member Code example CopyElements(Document, ICollection ElementId , Document, Transform, CopyPasteOptions) Copies a set of elements from source document to destination document.
Public method Static member Code example CopyElements(View, ICollection ElementId , View, Transform, CopyPasteOptions) Copies a set of elements from source view to destination view.
Public method Static member GetTransformFromViewToView Returns a transformation that is applied to elements when copying from one view to another view.
Public method Static member Code example MirrorElement Creates a mirrored copy of an element about a given plane.
Public method Static member MirrorElements Mirrors a set of elements about a given plane.
Public method Static member Code example MoveElement Moves one element by a given transformation.
Public method Static member MoveElements Moves a set of elements by a given transformation.
Public method Static member Code example RotateElement Rotates an element about the given axis and angle.
Public method Static member RotateElements Rotates a set of elements about the given axis and angle.
Top
See Also