Rebar
Get
|
Note: This API is now obsolete.
Gets the termination's out of plane rotation angle at the specified end. The rotation angle it's the same for both hook and crank.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.GetTerminationRotationAngle instead.")]
public double GetHookRotationAngle(
int end
)
Parameters
- end Int32
- 0 for the start, 1 for the end.
Return Value
DoubleReturns the termination's out of plane rotation angle at the specified end. The rotation angle it's the same for both hook and crank.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | end must be 0 or 1. |