Slab
|
An object used for Slab Shape Editing.

System
Object
Autodesk.Revit.DB SlabShapeEditor
Autodesk.Revit.DB SlabShapeEditor
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The SlabShapeEditor type exposes the following members.

Name | Description | |
---|---|---|
![]() |
IsEnabled | Identifies if the slab shape editing functionality is enabled. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
SlabShapeCreases | All of the creases that can be edited. |
![]() |
SlabShapeVertices | All of the vertices that can be edited. |

Name | Description | |
---|---|---|
![]() |
AddPoint | Add a point to the element. |
![]() |
AddPoints | |
![]() |
AddSplitLine | Add a split line to the element. |
![]() |
CreateCreasesFromFoldingLines | |
![]() |
DeletePoint | Delete a SlabShapeVertex from the element. |
![]() |
Dispose | Releases all resources used by the SlabShapeEditor |
![]() |
Enable | Enables the slab shape editing functionality. |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor. |
![]() |
ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor. |
![]() |
PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab. |
![]() |
ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.