Analytical
|
Represents the data and parameters of electrical analytical node.

System
Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalEquipmentLoadData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The AnalyticalDistributionNodePropertyData type exposes the following members.

Name | Description | |
---|---|---|
![]() |
ConnectedPhases | The electrical connected phases of the electrical analytical node to its upstream node. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the AnalyticalDistributionNodePropertyData |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |