Analytical
|
Represents the data and parameters of a power distributable node.
A power distribution node is an electrical analytical node with a distribution system which defines the connection rules between
upstream and downstream electrical analytical nodes.

System
Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalBusData
Autodesk.Revit.DB.Electrical AnalyticalPowerSourceData
Autodesk.Revit.DB.Electrical AnalyticalTransferSwitchData
Autodesk.Revit.DB.Electrical AnalyticalTransformerData
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalBusData
Autodesk.Revit.DB.Electrical AnalyticalPowerSourceData
Autodesk.Revit.DB.Electrical AnalyticalTransferSwitchData
Autodesk.Revit.DB.Electrical AnalyticalTransformerData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The AnalyticalPowerDistributableNodeData type exposes the following members.

Name | Description | |
---|---|---|
![]() |
AssignedPhasesNumber | The number of electrical phases assigned through the distribution system of the power distributable node. |
![]() |
AssignedVoltage | The voltage assigned through the distribution system of the power distributable node. |
![]() |
ConnectedPhases |
The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData ) |
![]() |
DistributionSystem | The distribution system of the power distributable node. |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData ) |

Name | Description | |
---|---|---|
![]() |
Dispose |
(Inherited from AnalyticalDistributionNodePropertyData ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetAllAvailableConnectedPhasesOnDownstream | Get all the available electrical connected phases that this power distributable node can provide to the downstream node. |
![]() |
GetApparentPerPhaseResults | Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node. |
![]() |
GetConnectedPhasesOnDownstream | Get the electrical connected phases of the downstream node. |
![]() |
GetDemandPerPhaseResults | Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
SetConnectedPhasesOnDownstream | Set the electrical connected phases of the downstream node. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |