GetHookOrientation Method


Rebar Get Hook Orientation Method

Note: This API is now obsolete.

Returns the orientation of the termination's plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal. The orientation it's the same for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.GetTerminationOrientation instead.")]
public RebarHookOrientation GetHookOrientation(
	int end
)

Parameters

end Int32
0 for the start termination, 1 for the end termination.

Return Value

RebarHookOrientation
Value = Right: The termination is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The termination is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
See Also