SetTerminationOrientation Method


Rebar Set Termination Orientation Method

Sets the orientation of the termination's (e.g. hook, crank) plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetTerminationOrientation(
	int end,
	RebarTerminationOrientation terminationOrientation
)

Parameters

end Int32
0 for the start termination, 1 for the end termination.
terminationOrientation RebarTerminationOrientation

Only two values are permitted:

Value = Right: The termination is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Value = Left: The termination is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also