SetCrankStraightLengthOverride Method


Rebar Set Crank Straight Length Override Method

Sets the crank straight length at the indicated bar end as an override value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankStraightLengthOverride(
	int end,
	double crankStraightLength
)

Parameters

end Int32
The bar end.
crankStraightLength Double
The crank straigth length.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException The bar does not have a valid Rebar Crank Type at the end. -or- The ability to override crank lengths is not enabled for this rebar instance. Use enableCrankLengthOverride(true) to enable it.
Remarks
When the crank straight length is set, the crank ratio is keeping the same value. The offset length and angled length are adjusted.
See Also