MaxSpacing Property


Rebar Max Spacing Property

Identifies the maximum spacing between rebar in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public double MaxSpacing { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The maxSpacing isn't bigger than 0.0.
InapplicableDataException This rebar element represents a single bar (the layout rule is Single). -or- When setting this property: The rebar set layout does not permit changing the maximum spacing.
Remarks
The maximum spacing can be set for rebar sets with layout rule MaximumSpacing, MinimumClearSpacing, or NumberWithSpacing.
See Also