GetPropertyMappingInfos Method


IFCParameter Template Get Property Mapping Infos Method

Creates an array of property mappings contained in the property set according to provided selection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<IFCPropertyMappingInfo> GetPropertyMappingInfos(
	PropertySetupType propertySetupType,
	string propertySetName,
	PropertySelectionType propertySelectionType
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySetName String
The property set name.
propertySelectionType PropertySelectionType
The property selection type.

Return Value

IList IFCPropertyMappingInfo
The array of the property mappings in the property set.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also