HookAngle0 Property


Rebar Bend Data Hook Angle 0 Property

The angle (in degrees) of the hook at the start. Must be at least 0 and no more than 180. If the value is 0 it means that there is no hook. The default value is 0. When setting from 0 to another value, all crank lengths for start will be set to 0. When setting this value to 0 HookLength0 will be set to 0.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public int HookAngle0 { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: hookAngle0 must be at least 0 and no more than 180.
See Also