Rebar
Get
|
Gets the crank angled length at the indicated bar end.
If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- end Int32
- The bar end.
Return Value
DoubleReturns the crank angled length.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | end must be 0 or 1. |
InvalidOperationException | The bar does not have a valid Rebar Crank Type at the end. |