Create Method


Rebar Shape Create(Document, Rebar Shape Definition, Rebar Shape Multiplanar Definition, Rebar Style, Stirrup Tie Attachment Type, Int 32, Rebar Hook Orientation, Int 32, Rebar Hook Orientation, Int 32) Method

Note: This API is now obsolete.

Create a new instance of a Rebar Shape, which defines the shape of a rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.Create(Document doc, RebarShapeDefinition definition, RebarShapeMultiplanarDefinition multiplanarDefinition, RebarStyle style, StirrupTieAttachmentType attachmentType, int higherEnd, RebarShapeTerminationsData rebarShapeTerminationsData) instead")]
public static RebarShape Create(
	Document doc,
	RebarShapeDefinition definition,
	RebarShapeMultiplanarDefinition multiplanarDefinition,
	RebarStyle style,
	StirrupTieAttachmentType attachmentType,
	int startHookAngle,
	RebarHookOrientation startHookOrientation,
	int endHookAngle,
	RebarHookOrientation endHookOrientation,
	int higherEnd
)

Parameters

doc Document
A document to contain the RebarShape.
definition RebarShapeDefinition
The definition of the rebar shape, as a set of curves in a plane driven by parameters.
multiplanarDefinition RebarShapeMultiplanarDefinition
If not null, the created RebarShape will be a 3D shape. The shape is built out of the planar RebarShapeDefinition, with additional out-of-plane segments defined by the RebarShapeMultiplanarDefinition object. Not supported in conjunction with RebarShapeDefinitionByArc of type Spiral or LappedCircle.
style RebarStyle
Whether the shape is to be used as a standard bar or a stirrup/tie.
attachmentType StirrupTieAttachmentType
When the style is stirrup/tie, specify whether it will attach to the interior of cover (cover is measured to the stirrups), or to the exterior of cover (cover is measured to the standard bars). Ignored when the style is Standard.
startHookAngle Int32
The start hook angle, expressed as an integral number of degrees. If 0, the shape will have no start hook. Common values are 0, 90, 135, and 180.
startHookOrientation RebarHookOrientation
The orientation of the start hook. Ignored when startHookAngle is 0.
endHookAngle Int32
The end hook angle, expressed as an integral number of degrees. If 0, the shape will have no end hook. Common values are 0, 90, 135, and 180.
endHookOrientation RebarHookOrientation
The orientation of the end hook. Ignored when endHookAngle is 0.
higherEnd Int32
When the rebar crosses itself, one end will be "lifted" to avoid self-intersection. Specify which end should be lifted: 0 for start, 1 for end.

Return Value

RebarShape
A new RebarShape instance.
Exceptions
Exception Condition
ArgumentException definition is linked to a Document other than doc. -or- A multiplanar definition is specified when the given RebarShapeDefinition does not support it. The following RebarShapeDefinitions do not support multiplanar: a simple line; spiral; lapped circle. -or- The DepthParamId property of multiplanarDefinition is invalid or has not been added to definition.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException startHookAngle must be at least 0 and no more than 180. -or- endHookAngle must be at least 0 and no more than 180. -or- higherEnd must be 0 or 1. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also