Rebar
|
Sets the crank offset multiplier value.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public static void SetCrankOffsetMultiplier(
Document document,
ElementId rebarCrankTypeId,
double crankOffsetMultiplier
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for crankOffsetMultiplier must be positive. |