SetHookRotationAngle Method


Rebar Set Hook Rotation Angle Method

Note: This API is now obsolete.

Sets the terminitation's out of plane hook rotation angle at the specified end. The rotation angle it's the same for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.SetTerminationRotationAngle instead.")]
public void SetHookRotationAngle(
	double rotationAngle,
	int end
)

Parameters

rotationAngle Double
The termination's out of plane rotation angle at the specified end. The rotation angle it's the same for both hook and crank.
end Int32
0 for the start, 1 for the end.
Exceptions
Exception Condition
ArgumentException The given value for rotationAngle is not finite
ArgumentOutOfRangeException end must be 0 or 1.
See Also