GetCrankRatio Method


Rebar Get Crank Ratio Method

Gets the crank ratio at the indicated bar end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public double GetCrankRatio(
	int end
)

Parameters

end Int32
The bar end.

Return Value

Double
Returns the crank ratio.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException The bar does not have a valid Rebar Crank Type at the end.
Remarks
The crank slope is 1/crankRatio. If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
See Also