FindPropertyMappingInfo(PropertySetupType, String, String) Method


IFCParameter Template Find Property Mapping Info(Property Setup Type, String, String) Method

Finds the property mapping info in the property set by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IFCPropertyMappingInfo FindPropertyMappingInfo(
	PropertySetupType propertySetupType,
	string propertySetName,
	string propertyName
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySetName String
The property set name.
propertyName String
The property name.

Return Value

IFCPropertyMappingInfo
The property mapping info or if not found.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also