SetCrankLengthOverride Method


Rebar Set Crank Length Override Method

Sets the crank length at the indicated bar end as an override value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankLengthOverride(
	int end,
	double crankLength
)

Parameters

end Int32
The bar end.
crankLength Double
The crank length.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException The bar does not have a valid Rebar Crank Type at the end. -or- The ability to override crank lengths is not enabled for this rebar instance. Use enableCrankLengthOverride(true) to enable it.
See Also