Rebar
|
Constructs a new RebarBendData using the bar type, style and termination's values.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public RebarBendData(
RebarBarType barType,
RebarStyle style,
BarTerminationsData barTerminationsData
)
Parameters
- barType RebarBarType
- The RebarBarType.
- style RebarStyle
- The style.
- barTerminationsData BarTerminationsData
- The bar terminaions data.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |