SetCrankAngledLengthOverride Method


Rebar Set Crank Angled Length Override Method

Sets the crank angled length at the indicated bar end as an override value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankAngledLengthOverride(
	int end,
	double crankAngledLength
)

Parameters

end Int32
The bar end.
crankAngledLength Double
The crank angled length.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException The bar does not have a valid Rebar Crank Type at the end. -or- The ability to override crank lengths is not enabled for this rebar instance. Use enableCrankLengthOverride(true) to enable it.
Remarks
When the crank angled length is set, the crank ratio is keeping the same value. The offset length and straight length are adjusted.
See Also