Nurbs
|
A class used to represent the definition of a NURBS surface.

System
Object
Autodesk.Revit.DB NurbsSurfaceData
Autodesk.Revit.DB NurbsSurfaceData
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The NurbsSurfaceData type exposes the following members.

Name | Description | |
---|---|---|
![]() |
NurbsSurfaceData | Copy constructor. |

Name | Description | |
---|---|---|
![]() |
DegreeU | The degree of the spline in the u-direction. |
![]() |
DegreeV | The degree of the spline in the v-direction. |
![]() |
IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() |
ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface. |

Name | Description | |
---|---|---|
![]() ![]() |
Create | |
![]() |
Dispose | Releases all resources used by the NurbsSurfaceData |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetControlPoint | Get the list of control points. |
![]() |
GetControlPoints | Get the list of control points. |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetKnotsU | Get the list of knots in the u-direction. |
![]() |
GetKnotsV | Get the list of knots in the v-direction. |
![]() |
GetKnotU | Get the knot in the u-direction. |
![]() |
GetKnotV | Get the knot in the v-direction. |
![]() |
GetNumberOfControlPoints | Get the number of control points. |
![]() |
GetNumberOfKnotsU | Get the number of knots in the u-direction. |
![]() |
GetNumberOfKnotsV | Get the number of knots in the v-direction. |
![]() |
GetNumberOfWeights | Get the number of weights. |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
GetWeight | Get the weight. |
![]() |
GetWeights | Get the list of weights. |
![]() |
IsValid | Check if the object contains a valid NurbsSurfaceData. |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |