GetCrankTypeId Method


Rebar Get Crank Type Id Method

Gets the id of the Crank Type id that is applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId GetCrankTypeId(
	int end
)

Parameters

end Int32
0 for the start Crank, 1 for the end Crank.

Return Value

ElementId
Returns the id of a Crank Type, or invalidElementId if the rebar has no crank at the specified end.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
Remarks
Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
See Also