AddPropertyMappingInfo Method


IFCParameter Template Add Property Mapping Info Method

Adds a property mapping info to the property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void AddPropertyMappingInfo(
	PropertySetupType propertySetupType,
	string propertySetName,
	IFCPropertyMappingInfo propertyMappingInfo
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySetName String
The property set name.
propertyMappingInfo IFCPropertyMappingInfo
The property mapping info.
Exceptions
Exception Condition
ArgumentException The mapping info is invalid. -or- A property set with the given name is not present in the template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also