CreateRebarCrankType Method


Rebar Crank Type Utils Create Rebar Crank Type Method

Creates a Rebar Crank Type element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static ElementType CreateRebarCrankType(
	Document document,
	string typeName
)

Parameters

document Document
The document.
typeName String
The Rebar Crank Type name.

Return Value

ElementType
The Rebar Crank Type.
Exceptions
Exception Condition
ArgumentException The given value for typeName cannot be an empty string. -or- The given value for typeName cannot include prohibited characters. -or- The given value for typeName is already in use by another Rebar Crank Type.
ArgumentNullException A non-optional argument was null
See Also