SetLayerFunction Method


Compound Structure Set Layer Function Method

Sets the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetLayerFunction(
	int layerIdx,
	MaterialFunctionAssignment function
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
function MaterialFunctionAssignment
The function of the layer.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also