SetCrankTypeId Method


Rebar Set Crank Type Id Method

Sets the id of the Crank Type to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankTypeId(
	int end,
	ElementId crankTypeId
)

Parameters

end Int32
0 for the start Crank, 1 for the end Crank.
crankTypeId ElementId
The id of a Crank Type element, or invalidElementId if the rebar should have no crank at the specified end.
Exceptions
Exception Condition
ArgumentException the parameter crankTypeId is not a Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
See Also